Loading issues in JUNE

Incident Report for JUNE

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 19:01 CET

Monitoring

The issue has been fixed, we are monitoring if everything works as expected.
Posted Mar 12, 2026 - 18:56 CET

Identified

Dear customers, we are currently experiencing some issues with loading and displaying of JUNE.
The error has already been identified and will be fixed shortly.
Posted Mar 12, 2026 - 18:06 CET
This incident affected: Login.